Support ⇒ Troubleshootings ⇒ You tried to access this page through a bad link... ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexTroubleshootings

You tried to access this page through a bad link... Reply to topic


Hi guys, i have just upgraded my web hosting from Shared Hosting to Cloud Hosting.
I had to change to DB details, clear cache and cookies but it works for the most part.

When i edit/change/save anything in the admin area i get a message
"You tried to access this page through a bad link..."

I also notice i can't post in forums, says page does not exist?
/Forums/posting/mode=newtopic/f=1.html


Any help appreciated.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Litespeed/Apache2.4.23/MySQL5.5.42/PHP 5.6.25/DF 9.4.0.0


Had exactly the same problem when I switched host a few years ago and the new host used a cloud hosting arrangement (multiple clustered nodes).

I had to do this :-

1. Make a folder at a level below website root (outside "public_html" if your host uses that) called "sessions" (though name doesn't really matter).

2. Add this line to the bottom of /includes/config.php

session_save_path('/path/to/sessions/');

Gaming League / Cup - www.leaguecms.co.uk :: Other DragonFly modules - www.cmsdreams.co.uk

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


Thanks Kendle, im now getting the message
"Please enable cookies to post on this site. If you feel that you have reached this message in error please go back to the preceding page and post again"
when i try to do anything in login as admin section.

I noticed if i click on a download cat i get a 404 error.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Litespeed/Apache2.4.23/MySQL5.5.42/PHP 5.6.25/DF 9.4.0.0


Have you cleared browser and website cache?

Clear your browser history depending on which browser you're using, clear the website cache by deleting the contents of the /cache folder (apart from a file called .htaccess in there).

Gaming League / Cup - www.leaguecms.co.uk :: Other DragonFly modules - www.cmsdreams.co.uk

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


Yep that was the first thing i did, i just did it again and i get the cookie error, interesting though if i click back a page i can login the admin area. I can navigate but if i make a change i get the cookie error again.
I use FFox and checked with IE both the same.

Downloads, Forums, Content and a few other modules a throwing 404 errors

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Litespeed/Apache2.4.23/MySQL5.5.42/PHP 5.6.25/DF 9.4.0.0


Did you changed domain name too?

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


no, same domain.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Litespeed/Apache2.4.23/MySQL5.5.42/PHP 5.6.25/DF 9.4.0.0


I dropped the DB and re imported - no different.
Uploaded a fresh copy over the old one (clearing cache and deleting /includes folder first) - no different

The domain DNS was changed when i moved to cloud but same .com name.
I also changed
DB Host from localhost to mysql-5...
DB Name
DB User
DB Pass

cookie settings as default settings.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Litespeed/Apache2.4.23/MySQL5.5.42/PHP 5.6.25/DF 9.4.0.0


Is there anything that can be done to save my site?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Litespeed/Apache2.4.23/MySQL5.5.42/PHP 5.6.25/DF 9.4.0.0


i just made a sub directory with a fresh copy of DF and a new DB.
It was getting the bad link message, but once i closed the the web browser and went back to the site i start getting the cookie error.

Im at a loss, is this a server issue?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Litespeed/Apache2.4.23/MySQL5.5.42/PHP 5.6.25/DF 9.4.0.0


I seem to be getting somewhere
If i login as a user and admin as same time i dont get the cookie error but i do get the bad link error.

The bad link error seems to be in the sessions area of admin

admin/modules/cpgmm.php
Notice line 13: Undefined index: admin

admin/modules/modules.php
Notice line 15: Undefined index: admin
if ($CPG_SESS['admin']['page'] != 'modules') { cpg_error(_ERROR_BAD_LINK, _SEC_ERROR); }

Still getting the 404 errors as well Sad

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Litespeed/Apache2.4.23/MySQL5.5.42/PHP 5.6.25/DF 9.4.0.0

Last edited by BobCat on Fri Jul 25, 2014 3:21 am; edited 1 time in total


/home/user/sessions/

did you set permissions chmod to 755 or 777

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux / 2.2.6 / 5.0.45 / 5.2.4 / Dragonfly (9.2.1)


i dont have the path /user/sessions/
i have /public_html/

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Litespeed/Apache2.4.23/MySQL5.5.42/PHP 5.6.25/DF 9.4.0.0


i've been getting a few emails

On //Forums/viewtopic/p=134.html
While executing query "SELECT * FROM cms_users WHERE user_id=1"

the following error occured: Table 'delta_nova_outpost_com.cms_users' doesn't exist

In: /clientdata/apache-www/n/o/nova-outpost.com/www/includes/classes/cpg_member.php on line: 66

line 66 is
$result = $db->sql_query('SELECT * FROM '.$user_prefix.'_users WHERE user_id='.$uid);

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Litespeed/Apache2.4.23/MySQL5.5.42/PHP 5.6.25/DF 9.4.0.0


SOLVED this issue of bad link.
My host tech support edited the session in config file and it is working.

Im still getting the 404 with modules though.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Litespeed/Apache2.4.23/MySQL5.5.42/PHP 5.6.25/DF 9.4.0.0

All times are UTC


Jump to: