Support ⇒ New installations ⇒ error-install.php ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexNew installations

error-install.php Reply to topic

Go to page 1, 2 Next

Uploaded afresh copy 9.4 run installer , everything looks good . after db config page then i get

On /install.php
While executing query "SHOW VARIABLES"

the following error occured: Access denied for user 'root'@'localhost' (using password: NO)

In: /home/inzanemi/public_html/install.php on line: 77

have edited config.php with correct info.
3rd try same thing
now page stuck on db page ,connection to server failed.
the lines in install.php

76:function get_db_vars($db) {
77:return $db->get_details();

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
xp/2.4.18/5.1.73/5.5.35/9.4


Your MySQL user has not the correct privileges.
Do you know how to configure MySQL users and grant them privileges?

Btw you say your server OS is XP, there is no such thing.
If you mean Windows XP read this!

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial

Last edited by DJ Maze on Tue Aug 23, 2016 9:32 pm; edited 1 time in total


yes mysql user does have privileges to the dbname. have made 3 dif ones n get same error. have been doin this a long time


and yes i no i typed in wrong server os its linux .

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
xp/2.4.18/5.1.73/5.5.35/9.4


What happens when you try to install the new v10?
dragonflycms.org/downl...cms-10.tgz

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial


all i downloaded was the Dragonfly9.4.0.0 didnt see a v10

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
xp/2.4.18/5.1.73/5.5.35/9.4


ok i downloaded it off your link , is their an installer.php with it ?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
xp/2.4.18/5.1.73/5.5.35/9.4


ok i figured it out , still didnt werk

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
xp/2.4.18/5.1.73/5.5.35/9.4


have contacted my hosting to see if their is a problem their thanks for helping

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
xp/2.4.18/5.1.73/5.5.35/9.4


found these 2 errors in cache erro log
CMS Error includes/poodle/kernels/dragonfly.php line 208: Access denied for user 'root'@'localhost' (using password: NO)
PHP Warning includes/poodle/sql/adapter/mysqli.php line 88: mysqli::real_connect(): (28000/1045): Access denied for user 'root'@'localhost' (using password: NO)

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
xp/2.4.18/5.1.73/5.5.35/9.4


If you have shared hosting (Plesk, cPanel, DirectAdmin, etc. etc.) then you configure a database and user there.
Say your control panel loginname is "johndoe", then:
  • a MySQL database like "johndoe_db" must be created
  • a MySQL user like "johndoe_dbuser" must be created
  • the MySQL user must be added to the MySQL database with all privileges
then use that database and user at Dragonfly install

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial


I know how to do the above .I just installed 2 different cms as a test , one on public_html and 1 in folder both by installers . they worked perfectly on the same dbs I was trying to use on Dragonfly install.
one cms was platinum nuke , the other was extreme evo

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
xp/2.4.18/5.1.73/5.5.35/9.4

Last edited by Critical on Wed Aug 24, 2016 9:36 pm; edited 1 time in total


Thanks for your information! That explains a lot about your good experience.

Something must be wrong on the server itself then.
"SHOW VARIABLES" not allowed is very strange
"Access denied for user 'root'@'localhost' (using password: NO)" is very strange

Is there an "includes/config.php" ?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial


No their is no includes/configure.php , this is very strange , the first time i have ever had trouble with an installer. All my server stats are green. I run the test/test.php , it showed all fine
.I get all green lights on 2nd page of installer for dragonfly , then fill out the next page with db , dbu , pw, prefix etc next page i get error , very strange indeed

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
xp/2.4.18/5.1.73/5.5.35/9.4


I did find the includes/config.php file you mentioned . I edited it with db , dbu , pw. Message I got was

We're glad you made the decision to use Dragonfly

We're sorry, but only MySQL 4 or higher is supported
Ask your server administrator about upgrading to MySQL 4 or higher
Your current version is: 10.0.20-MariaDB-cll-lve

So now I know I can't use it n my sql version I put up was wrong.

Thought I would pop in and let you know , much thanks

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
xp/2.4.18/5.1.73/5.5.35/9.4

Last edited by Critical on Mon Aug 29, 2016 8:33 pm; edited 1 time in total


MariaDB is also supported, the bug is a wrong check in /install/step3.php
It does a wrong version compare.
Delete on line 18
		if ($server['version'][0] < 4) {
			echo sprintf($instlang['s1_mysql'], $server['version']);
			return;
		}


Thanks for reporting

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial

Last edited by DJ Maze on Tue Aug 30, 2016 7:48 am; edited 2 times in total

All times are UTC
Go to page 1, 2 Next


Jump to: