Support ⇒ Explain Please ⇒ Admin Login ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexExplain Please

Admin Login Reply to topic


Hi im using DF9.4 i can log in as a user fast and easy but when i go to /admin.php and try to log in it just times out after a few minutes, any ideas what going on.
I have made no changes to the site this just happened this morning.
Oh i did update PHP to v5.6 a few weeks ago but nothing happened then only today?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Litespeed/Apache2.4.23/MySQL5.5.42/PHP 5.6.25/DF 9.4.0.0


ok this is happening on 2 site so must be server side, still lost for ideas Sad

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Litespeed/Apache2.4.23/MySQL5.5.42/PHP 5.6.25/DF 9.4.0.0


Got a message from host

Your site has spawned a huge number of frozen processes as you can see here:

910829 20 0 565m 48m 22m S 0.3 0.3 0:02.92 lsphp
917224 20 0 561m 40m 19m S 0.3 0.3 0:02.04 lsphp
911040 20 0 451m 25m 17m S 0.0 0.2 0:00.06 lsphp
913890 20 0 451m 25m 17m S 0.0 0.2 0:00.08 lsphp
917290 20 0 451m 25m 17m S 0.0 0.2 0:00.05 lsphp
917310 20 0 451m 25m 17m S 0.0 0.2 0:00.06 lsphp
917596 20 0 451m 25m 17m S 0.0 0.2 0:00.05 lsphp
917611 20 0 451m 25m 17m S 0.0 0.2 0:00.07 lsphp
917634 20 0 451m 25m 17m S 0.0 0.2 0:00.05 lsphp
917744 20 0 451m 25m 17m S 0.0 0.2 0:00.06 lsphp
917752 20 0 451m 25m 17m S 0.0 0.2 0:00.07 lsphp
917903 20 0 451m 25m 17m S 0.0 0.2 0:00.05 lsphp
917920 20 0 451m 25m 17m S 0.0 0.2 0:00.09 lsphp
919674 20 0 559m 38m 19m S 0.0 0.2 0:01.78 lsphp
921511 20 0 558m 39m 21m S 0.0 0.2 0:01.68 lsphp
921521 20 0 547m 29m 20m S 0.0 0.2 0:00.16 lsphp
921672 20 0 451m 25m 17m S 0.0 0.2 0:00.06 lsphp
921701 20 0 451m 25m 17m S 0.0 0.2 0:00.06 lsphp
921721 20 0 451m 25m 17m S 0.0 0.2 0:00.05 lsphp
921735 20 0 451m 25m 17m S 0.0 0.2 0:00.06 lsphp
921782 20 0 451m 25m 17m S 0.0 0.2 0:00.05 lsphp
921893 20 0 451m 25m 17m S 0.0 0.2 0:00.05 lsphp
921897 20 0 451m 25m 17m S 0.0 0.2 0:00.05 lsphp
921899 20 0 451m 25m 17m S 0.0 0.2 0:00.05 lsphp
921912 20 0 547m 28m 19m S 0.0 0.2 0:00.15 lsphp
921914 20 0 451m 25m 17m S 0.0 0.2 0:00.05 lsphp
921922 20 0 451m 25m 17m S 0.0 0.2 0:00.07 lsphp
921924 20 0 451m 25m 17m S 0.0 0.2 0:00.08 lsphp
921926 20 0 451m 25m 17m S 0.0 0.2 0:00.05 lsphp
921930 20 0 451m 25m 17m S 0.0 0.2 0:00.05 lsphp
921933 20 0 451m 25m 17m S 0.0 0.2 0:00.08 lsphp
921935 20 0 451m 25m 17m S 0.0 0.2 0:00.06 lsphp
921953 20 0 451m 25m 17m S 0.0 0.2 0:00.05 lsphp
921960 20 0 451m 25m 17m S 0.0 0.2 0:00.05 lsphp
921962 20 0 451m 25m 17m S 0.0 0.2 0:00.05 lsphp
936499 20 0 106m 24m 3020 S 0.0 0.2 0:00.02 cpaneld - servi
936510 20 0 104m 24m 2996 S 0.0 0.2 0:00.01 cpaneld - servi
936541 20 0 104m 23m 2944 S 0.0 0.2 0:00.00 cpaneld - servi
936542 20 0 104m 23m 2832 S 0.0 0.1 0:00.00 cpaneld - servi
936543 20 0 104m 23m 2832 S 0.0 0.1 0:00.00 cpaneld - servi
936548 20 0 104m 23m 2832 S 0.0 0.1 0:00.00 cpaneld - servi

I have now killed them for you and the site is accessible.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Litespeed/Apache2.4.23/MySQL5.5.42/PHP 5.6.25/DF 9.4.0.0


I've disabled forcing HTTPS on this server.
Does it work again?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial

Last edited by DJ Maze on Wed Dec 21, 2016 2:10 am; edited 1 time in total


So grab the latest version of v9 upload and hope it works?

What has caused the issue to begin with, any ideas?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Litespeed/Apache2.4.23/MySQL5.5.42/PHP 5.6.25/DF 9.4.0.0


get_fileinfo(), which is used to fetch update data, has bug to crash when a https request is made.

dragonflycms.org forces HTTPS now and that causes the trouble.
I've now made an exclusion when requesting the update.php
RewriteCond %{HTTPS} !=on [NC] RewriteCond %{REQUEST_URI} !update.php RewriteRule ^(.*) https://%{SERVER_NAME}/$1 [R,L]

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial

Last edited by DJ Maze on Wed Dec 21, 2016 2:48 am; edited 2 times in total


Solved

Uploaded the admin folder and it fixed the issue.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Litespeed/Apache2.4.23/MySQL5.5.42/PHP 5.6.25/DF 9.4.0.0

All times are UTC


Jump to: