Support ⇒ Dragonfly CMS v10 ⇒ Can't upload avatar ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexDragonfly CMS v10

Can't upload avatar Reply to topic


Since a recent update (not sure which one), I can no longer upload an avatar.
When I select a picture from my local machine, the image appears above the save button, but after hitting save, the avatar is gone.

I don't see any errors, and in the database, my avatar is blank.
I tried switching to the default theme in case it was that, but it didn't work either.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):

Last edited by hybrid on Tue Feb 07, 2017 12:30 pm; edited 1 time in total


It seems to work OK here.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


Actually it's not just uploading. None of the avatar options work.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


Strange, i just registered on your website and the avatar is changed.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial


Very weird. So what would be the difference between a new and existing user?

You had another username on the site "maarten". Can you see if that one works for you?
I tried a png because I noticed yours is png, but no difference for me.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


This morning I can do it. Very weird.
I did update the site last night when a user told me they couldn't update their avatar.
So maybe the update fixed it, but caching stopped it working for a while?

I can't think of any other reason it would just start working when I haven't touched anything since I posted this issue.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


The user who originally contacted me still has the same issue.
I've asked him to send me the pic he's trying to use.

I've also asked him to try changing to one of the avatars from the gallery.
This is a really strange one. I still can't explain why mine just started working today.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


Very strange indeed. Maybe a write permissions issue?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial


Apache owns the avatars dir, so it shouldn't be.
And that wouldn't allow you or I do it.

Write permissions would show up in the error log too wouldn't it?
When you choose to upload from your computer, and it displays just above the save button - is that displaying locally just within the browser, or is it already uploaded at that point?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


It just shows a preview, it is NOT uploaded yet.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial

All times are UTC


Jump to: