Support ⇒ Dragonfly CMS v10 ⇒ DF Upgrade from 9.4 errors ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexDragonfly CMS v10

DF Upgrade from 9.4 errors Reply to topic


Hi @all,

actually i´m planning to upgrade from 9.4 to Dragonfly V10 - at this time testing locally with wampserver

Apache 2.4.27 - PHP 5.6.31
MySQL 5.7.19
PHP 5.6.31 for CLI (Command-Line Interface

When starting the installer following error occurs:


Pre-upgrade steps:

Synchroniziere Datenbank Daten:

Synchroniziere Datenbank Schemen:
core . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
auth . . . . . . . . . . . .

Synchroniziere Datenbank Daten:
core . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
auth . . . . . . . . . . . . . . . . . . . . . . .

Synchronization erfolgreich abgeschlossen

Führe zusätzliche Queries aus:
Table 'cpg._comments' doesn't exist

Bitte Fehler an das CPG-Nuke Dev Team melden
Installation kann nicht fortgesetz werden


can anybody please help?

regards
merlin

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Centos / DF 9.4


Could you tell me which modules are installed?
Looks like a News or Coppermine module issue.
There might be an error report in /cache/error.2018-W03.log

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial

Last edited by DJ Maze on Fri Jan 19, 2018 5:02 pm; edited 1 time in total


hi,
first of all - i was not able to login with my user "merlin" again - even password reset did not work

no i´ve checked: cache/error.2018-W03.log - please find file attached

following modueles are installed in my old 9.4 installation:

Cache Manager
Community Forums
Contact Us
Content
CPGNuCalendar
dfmaps
DF MSAnalysis
Downloads
Encyclopedia
FAQ - Help
Groups
IM
Links
login
Members Delete
Members List
Metatag Manager
My Account
My Private Messages
News
Newsletters
Personality
Photo Gallery
Post Ads
Search
Statistics
Stories Archive
Surveys
Tell a Friend
Top 5
Topics
Attachment: error.2018-W03.txt
Description
Filename error.2018-W03.txt
Filesize 17.43 KiB
Downloaded 4 Time(s)
You are not allowed to view/download this attachment

Please enter your server specs in your user profile! 😢


Markus Merk wrote
hi,
first of all - i was not able to login with my user "merlin" again - even password reset did not work

What "did not work"? Didn't you get an e-mail? You typed in a new password but failed? What?

Thank you for the error log!
PHP Notice includes\dragonfly\setup\upgrade.php line 114: Undefined variable: prefix
This is the problem. It is fixed, you can download a new version

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial


first of all, thx for new version - I´ll try asap

regarding the login of my user (not cross authentication with facebook) - i´ve resetted my password, got Mail with link to reset password - changed password and got: "The provided information is unknown or incorrect. Please try again"

then i´ve resettet the password again (to another password) and got same issue - if it will help to fix, I can provide screenshots

Please enter your server specs in your user profile! 😢


I did not get my old 9.4 installation updated - probably it´s a good idea to deactivate all not standard included modules before update-process ?

then i tried to do a fresh installation - installer finished without any problem but wen I login into admin-panel and try to entry main settings (http://localhost/?admin&op=settings) í´ll get the following screen :-/
Logfile attached

many thanks for your support!
Attachment: df10.JPG
Description
Filesize 192.50 KiB
Viewed 2 Time(s)
You are not allowed to view/download this attachment
Attachment: error.2018-W04.log.zip
Description
Filename error.2018-W04.log.zip
Filesize 38.74 KiB
Downloaded 1 Time(s)
You are not allowed to view/download this attachment

Please enter your server specs in your user profile! 😢


Thank you for all the information!

Could you modify includes/poodle/classes/random.php line 40
- $key = \Poodle\UUID::generate(); + $key = sha1($_SERVER['REMOTE_ADDR']);
Problem is caused by an infinite loop in PHP 5. The function random_bytes() does not exists which causes the error as mentioned in the error log.
It's fixed in the source, expect an update soon.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial

Last edited by DJ Maze on Mon Jan 22, 2018 7:25 pm; edited 2 times in total


Markus Merk wrote
first of all, thx for new version - I´ll try asap

regarding the login of my user (not cross authentication with facebook) - i´ve resetted my password, got Mail with link to reset password - changed password and got: "The provided information is unknown or incorrect. Please try again"

then i´ve resettet the password again (to another password) and got same issue - if it will help to fix, I can provide screenshots

Thanks for the info, in v10 there is a log system and there i find:
Poodle\Auth\Provider\Database#4: A database record was not found for merlin

I will investigate this issue

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial

All times are UTC


Jump to: