Dragonfly CMS v9 ⇒ IIS Specific Issues :: Archives ⇒ Problem with admin.php and login :: Archived ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexIIS Specific Issues

Archived ⇒ Problem with admin.php and login


After sucessfully installing CPG-Nuke 9.0.0 RC1 I can't log in using admin.php. When I try this it just shows me the standard windows login box.

Everything else seems to be working fine, I can access the site via index.php and is able to login with the admin user there.

Please advise!

Running on Windows 2000 with IIS 5.0, PHP 4.3.10 and MySQL 4.0.17

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
W2K/2.x/4.0.17/4.3.11/9.0.4


this is must be IIS problem, there is 9x IIS Help Board.

Firefox is my Favorite Browser

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Apache/1.3.34 (Unix)/4.0.25-standard/4.4.1/CVS


moved here

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux / 1.3.34 / 4.1.18 / 4.4.2 / CVS


Alright, did not have the time to wait around so I just installed Apache and everything works great.

Anyway if someone comes up with a solution regarding IIS just let me know.

Thanks!

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
W2K/2.x/4.0.17/4.3.11/9.0.4


hi Firelite,

Ive been running all my php cms on IIS - ranging from PHPnuke and IIS5 to dragonfly now on IIS6.

If you could give me some more to work on Im sure we'll be able to figure out what to do. Smile

Right off the bat I think this is a security issue. Doublecheck that all files in your site has atleast read/execute rights.

Regards

Ulf Thomas Johansen

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Windows 2003/IIS 6.0/4.1.10/5.0.3/CVS


Thanks man, will let you know when I decide to put up IIS again.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
W2K/2.x/4.0.17/4.3.11/9.0.4


I'd like to know if anyone has had a solution to IIS and RC1

I jsut installed everything over, worked fine, but stupid me forgot to turn off maintenance mode. Now when I try to login to admin.php, originally it wanted the username adn password for "" on a windows logon prompt, now it wont even let me in at all, giving me HTTP 401.5 - Unauthorized: Authorization by ISAPI or CGI application failed.

Quite puzzling since nothign there is running.

Any thoughs would be great.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/2.x/4.x/4.x/9.RC1


FireLite wrote
After sucessfully installing CPG-Nuke 9.0.0 RC1 I can't log in using admin.php. When I try this it just shows me the standard windows login box.


My first post here...

I got this problem too and I don´t know what to do. Sad


I got two phpbb forums running on my server, one coppermine galley and some other stuff as well, But I have never got this "error" before.

Hope someone can help me!
Thanks,
/melvin

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Win2000 Adv Server/IIS/PHP?/CPG9


I have a couple ideas but I'd need to see debug output and a picture of the login window.

J.
j e r u v y a t y a h o o d o t c o m

Need help? Look here: www.dragonflycms.org/W...d=112.html
Need to chat? Look for me on irc.freenode.net

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Ubuntu7.10/Debian3.1 - 2.2.3/1.3.37 - 5.0.38/4.0.27 - 5.2.1/4.4.7 - CVS/9.1.2}


melvin wrote
FireLite wrote
After sucessfully installing CPG-Nuke 9.0.0 RC1 I can't log in using admin.php. When I try this it just shows me the standard windows login box.


My first post here...

I got this problem too and I don´t know what to do. Sad


I got two phpbb forums running on my server, one coppermine galley and some other stuff as well, But I have never got this "error" before.

Hope someone can help me!
Thanks,
/melvin


If I am not mistaking the reason for the 405.1 error is that you have not set up the correct extensions.

Start the Internet Information Services Management on your server, and navigate to server->Web Services Extensions. There you have to add the extension PHP and the required file to use it (x:\full\path\to\php.exe).

If that does not solve it verify that your whole CPG site has read/read execute, except for the Cache folder which needs all rights except for full control. In other words: Modify.

If it still doesn't work then you can download a utility called Filemon. This utility monitors the filesystem. Switch it on just when you try to open your site, and you can read through the log to check for errors.

Regards

Ulf Thomas Johansen

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Windows 2003/IIS 6.0/4.1.10/5.0.3/CVS


on my server 8.2 run great. 9.0.1 also.. but the admin.php shows me the windows login box too...
i installed it into a fresh web:

beta.kiteportal.ch

can you help me?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
W2003/Apache 2.0.5/MYSQL4.0.22/PHP5.1/CGPNuke 9.1.1


hardlocke wrote
on my server 8.2 run great. 9.0.1 also.. but the admin.php shows me the windows login box too...
i installed it into a fresh web:

beta.kiteportal.ch

can you help me?


This is, as the error message say, (by hitting cancel): You dont have access to the required files because the ACLs are incorrect. Please verify that the user which the website runs under have the required ACLs to access the files.

First locate the username of the website: IIS Manager, machinename, Web Sites, Default Web site (unless you've made a specific one), right click default website and choose properties, hit directory security and then the top edit button. This shows you the username, which will need to have a minimum of "Read/Execute" on all the files and folders where CPG is located. (And also modify on the cache folder)

If anonymous access is disabled (not checked) then all users will have to have their own user on your system to gain access. Wink

Regards

Ulf Thomas Johansen

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Windows 2003/IIS 6.0/4.1.10/5.0.3/CVS


everyone has "full control" rights on the whole site. only the admin.php doesn't work.
but now i found the solution.
i have upgraded from 8.2 on a new domain. now, the local path is different.....

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
W2003/Apache 2.0.5/MYSQL4.0.22/PHP5.1/CGPNuke 9.1.1


Goody. Smile

Regards

Ulf Thomas Johansen

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Windows 2003/IIS 6.0/4.1.10/5.0.3/CVS


I finally got it to work! Big grin

I deleted row #138 in config.php
header('HTTP/1.0 401 Unauthorized');


Well, I don´t know if it´s a good idea to do that but the dragonfly site is up and running now and I can log in!

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Win2000 Adv Server/IIS/PHP?/CPG9

All times are UTC