Dragonfly CMS v9 ⇒ IIS Specific Issues :: Archives ⇒ Problem with admin.php and login :: Archived ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexIIS Specific Issues

Archived ⇒ Problem with admin.php and login


melvin wrote
I finally got it to work! Big grin

I deleted row #138 in config.php
header('HTTP/1.0 401 Unauthorized');


Well, I don´t know if it´s a good idea to do that but the dragonfly site is up and running now and I can log in!


Wierd indeed, but I am not qualified to answer if that is the solution or not. Sad

Regards

Ulf Thomas Johansen

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Windows 2003/IIS 6.0/4.1.10/5.0.3/CVS


Does someone has the oppertunity to test and debug this ?

What i like to know is:
1) Are you using a proxy ?
2) Are you using a firewall or norton application ?
3) Does the server use IIS ?
4) When you access our admin.php, what do you see ?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial


no proxy, no firewall, but IIS 6.0
your admin.php looks good

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
W2003/Apache 2.0.5/MYSQL4.0.22/PHP5.1/CGPNuke 9.1.1


now i have upgraded to 9.0

and comment out in admin.php:
// header('HTTP/1.0 401 Unauthorized');
Now the IIS Login Pop-Up don't show and i can login.
i see all the admin icons on the page.
but if i click on a admin icon (eg: Users) i'm on the admin logon page again...
it's maybe a cookie or session problem with IIS?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
W2003/Apache 2.0.5/MYSQL4.0.22/PHP5.1/CGPNuke 9.1.1

All times are UTC