Support ⇒ Troubleshootings :: Archives ⇒ SMTP Mail on sub-domain doesn't work|settings are right :: Archived ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexTroubleshootings

Archived ⇒ SMTP Mail on sub-domain doesn't work|settings are right


Ive checked my smtp mail settings, but i still get errors when i do anything that involves sending mail

Could it be that having a

"+" in my user name makes it not work?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache 1.3/Mysql4/Php4/9.0 CVS/

Last edited by Dantarion on Fri Feb 04, 2005 2:40 pm; edited 1 time in total


a + is mostly marked as a "space"
try the url-code for the + which is %2B

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial


Will do and report back!
Thanks DJMaze!
------------
Edit
-----------------
I got an error, I dont think it has the wrond username

language/english/contact.php

* Notice line 20: Constant _YOURNAME already defined

includes/classes/smtp.php

* Warning line 110: fsockopen(): unable to connect to mail.dantar.net:25
-----------------------
I think my host might have fsockopen disabled....
------------------------------
EDIT

Okay its working now! I found out that if ur host used cpanel, so your mail server might be mail.domain.dom....

if your website is on subdomain.domain.com, then the socket gets blocked..

I fixed this by using localhost for smtp server!
--------
I hope other people read this, it had me puzzled for a few hours

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache 1.3/Mysql4/Php4/9.0 CVS/


i think i heave the same plob but not shore ...

put exemple ?

thk's

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache 2.0/5.0.26/5.1.5/9.1.1

All times are UTC