Dragonfly CMS v9 ⇒ IIS Specific Issues :: Archives ⇒ Cannot login using IIS :: Archived ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexIIS Specific Issues

Archived ⇒ Cannot login using IIS


My server specs are: Windows Server 2003, IIS 6, PHP 4.3.10, MySQL 4.0.23

I installed Dragonfly today, and when I created my superuser account it completed the installation and then went to admin.php to allow me to login. The problem is, whatever I type into the login it rejects, and just comes up with the login screen again, no errors. When I click cancel, it goes to HTTP error 401 "you are not authorized to view this page".

bfusion.serverempire.net

Is there a way to disable the IIS login and use the web login? One time when I clicked cancel, back and then forward, it used the web based login instead of IIS, and my login worked.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Windows Server 2003, IIS 6, PHP 4.3.10, MySQL 4.0.23


Try this file

Explanation:

IIS servers and IE have the bad habbit to manipulate every page that you try to view by replacing certain pages.
The pages that they overwrite send special header tags.
These headers are send thru PHP like
header('HTTP/1.0 401 Unauthorized');

We use those headers to inform proxies and search engines to NOT include the page in the system.
However we never thought of the fact that M$ likes to "own" your server and browser that deep.

Maybe IIS has a setting so you can avoid, but we all run Apache and Firefox so you or another IIS user has to come up with a solution.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial


i think
header("status: 404 Not Found")
Might Work in IIS

Firefox is my Favorite Browser

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Apache/1.3.34 (Unix)/4.0.25-standard/4.4.1/CVS

All times are UTC