Dragonfly CMS v9 ⇒ IIS Specific Issues :: Archives ⇒ Cannot change settings at all :: Archived ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexIIS Specific Issues

Archived ⇒ Cannot change settings at all


I installed the latest version of cpg on a win2k srv. Although i had no problem during the installation, i cannot make any changes in the cms at all. Here are the system info:

Setting Value

CMS Version 9.0.3.0
PHP Version 4.3.10
GD Version N/A
MySQL Version 4.0.24-nt
Session save_path c:\temp
Owner N/A (0)
Group 0
System Windows NT 5.0 build 2195
Build Date Dec 14 2004 17:46:48
Server API CGI/FastCGI
Virtual Directory Support enabled
Configuration File (php.ini) Path C:\PHP\php.ini
PHP API 20020918
PHP Extension 20020429
Zend Extension 20021010
Debug Build no
Thread Safety enabled
Registered PHP Streams php, http, ftp, compress.zlib

Can anybody help me please? Thanks in advance!

Rolling Eyes Rolling Eyes

Beware of Greeks baring gifts and tests

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Win2K/WinXP 2.8GHz


After you changed settings you must delete all files in the /www/cache/ folder manualy.

To avoid this you can do 1 of the following:

1. Setup the w2k srv properly so that PHP is allowed to delete files
2. delete the whole 'cache' folder which disables caching and makes your website slower

#1 would be the best solution but i doubt if the hosting company knows enough about their system to setup the permissions properly

#2 will still give issues with uploaded:
- avatars
- forum attachments
- coppermine
You must delete those files manualy

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial


Hey hey, it worked like a charm after i deleted the cache folder! Thanks alot!
Btw, you spoke of problems such as

#2 will still give issues with uploaded:
- avatars
- forum attachments
- coppermine

will i be able to upload avatars w/o using the cache folder?

P.S. Thanks again Very Happy Very Happy Very Happy

Beware of Greeks baring gifts and tests

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Win2K/WinXP 2.8GHz


1. Setup the w2k srv properly so that PHP is allowed to delete files

Do you know what you have todo to allow php to delete files? My friend is using IIS and have the same problem, but we choosed alternative #2, but we want ofcourse the best solution Smile

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
ClarkConnect 3.2/Apache 2.0.x/MySQL 4.1.x/PHP 4.3.x/Dragonfly CVS


I had this same problem... I run my own IIS server on my computer so what i did was to give the user (in my case "internet guest account")in windows that iis uses to serve anonymous http delete permissions to the cache directory in your dragonfly folder. Once I did that, when I changed settings in dragonfly they stuck! I'll post a picture of where I changed the permissions to show you easier. Hope that helps! Very Happy (I looked everywhere on how to fix this and couldn't find anything!)

-JoNn26

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Win2k3/IIS6/MySQL/PHP/CPGNuke versions: 9.0.6.1

All times are UTC