Dragonfly CMS v9 ⇒ Coppermine :: Archives ⇒ 0x0 images and thumbnails :: Archived ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum Index Modules & Blocks Coppermine ⇒ Archives

Archived ⇒ 0x0 images and thumbnails


i think a problem of safemode is been turn on, it in load.inc

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Apache/1.3.34 (Unix)/4.0.25-standard/4.4.1/CVS


i'm guessing your are talking about this:
/*
if (intval(ini_get(safe_mode))){
if (ini_get("safe_mode_include_dir")){
//SEE IF SAFE MODE IS SETUP CORRECTLY
if(!strpos(ini_get(safe_mode_include_dir),dirname(__FILE__))){
// cpg_die("_ERROR", "Safe mode is not setup properly, if it were '>dirname(__FILE__)." would be in the php config safe_mode_include_dir ".ini_get(safe_mode_include_dir).".",__FILE__,__LINE__);
}
}
}
*/

could someone please let me know what i have to do to configure that? I'm not real good with code, from what i can tell its maybe wanting to be pointed to my php.ini file? Maybe someone could give me an example of what this would look like with the values filled in?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Unsure/4.0.24/4.3.11/9.0.5.0?


Here the same problem, does anyone have working solution?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
FreeBSD/ 2 / 4.1.7 / 4.3.10 / 9.0.5.0


/me continues to wait patiently.........

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Unsure/4.0.24/4.3.11/9.0.5.0?


xfsunoles wrote
i think a problem of safemode is been turn on, it in load.inc


I can't find anything to turn on in load.inc? Just what is mentioned above, and here I can't find a solution. Could you please specify what you mean by this? I'm really looking for a solution, in this way the whole coppermine module is unusable.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
FreeBSD/ 2 / 4.1.7 / 4.3.10 / 9.0.5.0


I have the exact same problem and it is driving me nuts since there seems to be no solution to this Sad

I have tried to "disable" safe-mode by simply un-commenting the according lines but had no success whatsoever so far.

Without the gallery a big part of the whole site is rendered useless.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.6.17.8/MySQL: 4.1.22/PHP: 4.4.8/DF: 9.2.1.1


Update:

Finally got it working now:

It is not the load.inc that you have to modify but the "php.ini" on your root server (usually found in /etc folder). Simply Change "Safe Mode = On" to "Safe Mode = Off", reboot Apache and you are set Smile

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.6.17.8/MySQL: 4.1.22/PHP: 4.4.8/DF: 9.2.1.1


Golem wrote
Update:
It is not the load.inc that you have to modify but the "php.ini" on your root server (usually found in /etc folder). Simply Change "Safe Mode = On" to "Safe Mode = Off", reboot Apache and you are set Smile


I was expecting that this would be the solution, but when you host your site (like me) at a webhost there often isn't any possibilitie to modify this setting.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
FreeBSD/ 2 / 4.1.7 / 4.3.10 / 9.0.5.0


Have you tried to contact your host and ask him about this ? Since safe mode can be turned off locally, too (IIRC) they should be able to offer such a service if they are nice Smile

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.6.17.8/MySQL: 4.1.22/PHP: 4.4.8/DF: 9.2.1.1


here is the thing..........coppermine works just fine with safe mode on...... on the same webserver i have two instances of coppermine mine running just fine, these could be a newer version of coppermine than what dragonfly has incorportated..... Maybe there is a way to replace the version of coppermine that dragonfly uses with the newest version from the makers of coppermine? please help those of us that can't make changes to the php.ini and safemode.......we'll love you forever!

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Unsure/4.0.24/4.3.11/9.0.5.0?


This issue was posted in the coppermine help area around May 15th..... dragonflycms.org/Forum...=9935.html . We aren't getting alot of help on it and it has to do with older or dragonflys version of coppermine not working with safemode on. I've waited pretty patiently for help from a dragonfly developer to come back with a workaround for this, but after close to 3 months and my deadline for the site drawing near I'm pleading for help on this... I have about 4-5 beta sites up on the webspace right now and like dragonfly the best. I have e107 bridged with a newer version of coppermine working 100% and a standalone version of coppermine running as well. There are many people experiencing the same issue as me with dragonflys version of coppermine not working with safemode on. I, and i'm sure alot of the people having the same issues as i, would like to turn off safemode on our websites, but unfortunately we don't have access to the php.ini files or are not allowed to do this. BTW, i've tried using a .htaccess file to turn off safemode and that doesn't work either. So please help us with a workaround or i would even be will to use a newer standalone version of coppermine and somehow integrate it into dragonfly. I would just need instructions on what files can be replaced or how to bridge it successfully with coppermine.

Please help,
Thanks, Chad

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Unsure/4.0.24/4.3.11/9.0.5.0?


Fireblade: Check your database what size are the pictures stated at in there?
Can you give a link to your df test site? Send a admin login to my PM.
It appears that the picture are being resized look in you albums/... dir are there copies of the pics with normal- and thumb_ prefixes

AKA Akamu / Read these and your life will be successful | Find a Repair
--
Mods and Professional Support via YIM

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
win32 / Apache 1.3.33 / MySQL 4.1.16/PHP 4.4/CPG-CVS ( browsers: Mozilla 1.7.x / IE6 / Opera 8.0)


pm sent, sent link to admin login, username and pw. do whatever you can to try to fix this, i can always upload dragonfly again if something happens....... anything extra you need just email or pm me

thanks alot,
chad

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Unsure/4.0.24/4.3.11/9.0.5.0?


hey Akamu, just wondering if you had gotten time to login as admin and try to figure out what was going on......

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Unsure/4.0.24/4.3.11/9.0.5.0?


still haven't heard anything.....are you able to login with the info i pm'd you?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Unsure/4.0.24/4.3.11/9.0.5.0?

All times are UTC