Projects ⇒ Bugs ⇒ #1017: Coppermine "Batch add..." broken. ⇒ CPG Dragonfly™ CMS
Bug #1017 Coppermine "Batch add..." broken.
Project: Dragonfly 9.0.3 -> 9.3 Category: Coppermine
Submitted: Sunday, January 27, 2008 (13:51:56) Modified: Thursday, December 11, 2008 (07:07:53)
Status: No Feedback Assigned to:
PHP Version: 4.4.4 HTTPD Server: Apache 1.3
Votes: 2
Vote results:
Avg. Score: 4.0 ± 0.0 Reproduced: 0 of 2 (0.0%)

View/Vote Add Comment

Have you experienced this issue?
Rate the importance of this bug to you:

by: whatrevolution
Description:
------------
Dragonfly 9.2.0RC2
Dragonfly CVS Snapshot 200801271200

It simply doesn't work, anymore.

Reproduce code:
---------------
Upload some pictures. I scattered them across public categories, member categories, and some albums therein.

"Photo Gallery Tasks" -> "Batch add pictures"
/index.php?name=coppermine&file=searchnew



Actual result:
--------------
The search results are:

Select directory
userpics
10002
[...]

Both of the links are formed as this:
/index.php?name=coppermine&file=searchnew&startdir=userpics
/index.php?name=coppermine&file=searchnew&startdir=userpics/10002

But clicking through either link generates a page with this:
List of new pictures
Put pictures of "userpics/10002/" into

So, the form on /index.php?name=coppermine&file=searchnew&startdir=userpics , at least, looks wrong to me. Is that normal, because there are no images in the entire path?

What may be a separate issue is that I can NOT find a way to upload images into that userpics/ path. If it's there and not broken, I want to know, but if so it's definately a use case that's unreasonably difficult.

Bug? Feature? Forum?
by: darkgrue
Can confirm that modules/coppermine/searchnew.php appears to have a problem with certain filenames such that if a series of filenames appears in a batch upload, coppermine may ingore the existence of certain files in the series.

For example, in the following group of files, batch upload will refuse to acknowledge several of the files in the series:

Slingshot_01.jpg
Slingshot_02.jpg
Slingshot_03.jpg
Slingshot_04.jpg
Slingshot_05.jpg
Slingshot_06.jpg
Slingshot_07.jpg
Slingshot_08.jpg
Slingshot_09.jpg
Slingshot_10.jpg
Slingshot_11.jpg
Slingshot_12.jpg
by: NanoCaiordo
Try http://dragonflycms.org/Forums/viewtopic/p=144196/#144196
by: NanoCaiordo
whatrevolution and darkgrue reports seems to be totally different issues.

However please try:
includes/imaging/gd2.inc line 64

if ($dest_file == '') { header('Content-type: '.image_type_to_mime_type($dest_info[2])); + header('Connection: Close'); } elseif (!$force_extension) { $dest_file = image_file_to_extension($dest_file, $dest_info[2]); }
User Info

Welcome Anonymous



(Register)
Community

Support for DragonflyCMS in a other languages:

Deutsch
Español