Projects ⇒ Bugs ⇒ #593: Line breaks not occuring with Disable BBCode checked ⇒ CPG Dragonfly™ CMS
Bug #593 Line breaks not occuring with Disable BBCode checked
Project: Dragonfly 9.0.3 -> 9.3 Category: Forums
Submitted: Monday, July 18, 2005 (14:34:18) Modified: Monday, October 03, 2005 (02:50:46)
Status: Closed Assigned to:
PHP Version: Irrelevant HTTPD Server: Apache 1.3

View/Vote Add Comment

by: Tarun
Description:
------------
I noticed this morning on my site when a user posted a HijackThis log that it was pushed together.

Example:
Logfile of HijackThis v1.99.1 Scan saved at 11:26:27, on 11-7-2005 Platform: Windows 2000 SP4 (WinNT 5.00.2195) MSIE: Internet Explorer v6.00 SP1 (6.00.2800.1106)

Normally it would display as:
Logfile of HijackThis v1.99.1
Scan saved at 11:26:27, on 11-7-2005
Platform: Windows 2000 SP4 (WinNT 5.00.2195)
MSIE: Internet Explorer v6.00 SP1 (6.00.2800.1106)

I edited the post and change the text to:

xxx

xx

Upon display it would show as:
xxx xx

Re-editing the post I noticed Disable HTML and Disable BBCode were checked. After messing with editing the post, I found that with Disable BBCode checked the lines did not get broken as they should be.

With Disable BBCode unchecked it displayed as:
xxx

xx

Reproduce code:
---------------
Make any post with Disable BBCode checked and have any text such as:

xxx

xx

blah blah test

Expected result:
----------------
xxx

xx

blah blah test

Actual result:
--------------
xxx xx blah blah test
by: Tarun
Have also noticed the same thing happens on this site when you check Disable BBCode in the forums.
by: Brennor
This sounds like it has the same symptoms as this bug report:
dragonflycms.org/Proje...d=533.html

In which case, it might already be fixed in latest CVS.
by: Brennor
Please try using one of these CVS snapshots:

Latest tar.gz
Latest tar.bz2

Try version 9.16 of modules/Forums/viewtopic.php

That file should fix this problem. The latest CVS snapshot has the file in it, or download it here.
by: Tarun
I am using 9.16, it doesn't fix the problem.

I agree, it does sound like the same bug. Perhaps it has resurfaced.

It does occur on this site as well, it can be seen by doing the exact same as mentioned above.
by: xfsunoles
Do you have Text Demo in your site for this bug?
by: DJMaze
This bug has been fixed in the CVS.

Snapshots of the sources are packaged every 6 hours; this change
will be in the next snapshot. You can grab the snapshot at the
Downloads section.

Thank you for the report, and for helping us to make CPG-Nuke 9.0.3 -> 9.1 better.
User Info

Welcome Anonymous



(Register)
Community

Support for DragonflyCMS in a other languages:

Deutsch
Español